Jump to content

Welcome to Lambo Power!

Thank you for stopping by LamboPower.com. We are proud to announce our relaunch and redesign in 2019.

If you haven't already registered for a free account, take just a second and create an account today.

Welcome to the bullpen. 

 

Search the Community

Showing results for tags 'egear'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • SP Engineering
  • Discussion Groups
    • Lambo Power Exclusives
    • General
    • Off Topic
    • Dyno Runs
    • Lamborghini in the Press
    • Urus
    • Huracán
    • Huracán Twin Turbo
    • Aventador
    • Gallardo
    • Murciélago
    • Diablo
    • Countach
    • Vintage Lamborghini
  • Non-Lamborghini Luxury and Exotics
    • Audi/BMW/Mercedes Benz Power
    • Hypercars
    • Porsche Power
    • McLaren Power
    • Ford GT Power
    • Ferrari Power
    • RR Phantom | Bentley | Maybach
    • Nissan GT-R
    • Other Vehicles
  • Lambo Power VIP Lounge with Internet Business
    • Lambo Power VIP
  • Sponsor Classifieds
    • Lambo Power Novelties
    • SP Engineering
    • Classifieds
    • Vehicles For Sale
  • Lifestyle
    • Sports
    • Business
    • Watches
  • Required First Readings
  • Feedback
    • Got a question or complaint for the Moderators?

Blogs

  • Exclusive Andrew Romanowski Interview
  • Exclusive Ryan Fipke Interview

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 2 results

  1. Hi guys , today I start to see some smoke on the back of my car and what I see is the egear fluid tank have some sweating /leak .. IMG_2286.MOV
  2. Guest

    E gear light on

    Have a 06 battery was disconnected for awhile . Once battery got connected again I have a e gear light on that won’t go away and I can’t go to 3rd-6th without going to neautral each time then upshiffting I’ve checked fluid new battery clutch was replaced last year held in paddles but goes to auto mode and it won’t Shift to third
×
×
  • Create New...